Skip to content
NewA calmer, faster ZeroHour

CVE-2024-23807

CVSS 3.1
9.8 critical
EPSS
1%p74
Published
·
Modified
Analyze CVE-2024-23807 with Vani AIImpact, affected versions, exploitation status, mitigations and detection

Description · NVD

The Apache Xerces C++ XML parser on versions 3.0.0 before 3.2.5 contains a use-after-free error triggered during the scanning of external DTDs. Users are recommended to upgrade to version 3.2.5 which fixes the issue, or mitigate the issue by disabling DTD processing. This can be accomplished via the DOM using a standard parser feature, or via SAX using the XERCES_DISABLE_DTD environment variable. This issue has been disclosed before as CVE-2018-1311, but unfortunately that advisory incorrectly stated the issue would be fixed in version 3.2.3 or 3.2.4.

Vendors
apache
Products
xerces-c\+\+
Weakness
CWE-416
Vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

In the news

1 story