Skip to content
NewA calmer, faster ZeroHour

CVE-2026-24733

CVSS 3.1
3.7 low
EPSS
<1%p46
Published
·
Modified
Analyze CVE-2026-24733 with Vani AIImpact, affected versions, exploitation status, mitigations and detection

Description · NVD

Improper Input Validation vulnerability in Apache Tomcat. Tomcat did not limit HTTP/0.9 requests to the GET method. If a security constraint was configured to allow HEAD requests to a URI but deny GET requests, the user could bypass that constraint on GET requests by sending a (specification invalid) HEAD request using HTTP/0.9. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.14, from 10.1.0-M1 through 10.1.49, from 9.0.0.M1 through 9.0.112. Older, EOL versions are also affected. Users are recommended to upgrade to version 11.0.15 or later, 10.1.50 or later or 9.0.113 or later, which fixes the issue.

Vendors
apache
Products
tomcat
Weakness
CWE-20
Vector
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:N

In the news

1 story