Apache Camel flaws allow remote code execution and data theft
Eight critical and high issues span Camel K and Camel components, with fixes that differ by branch.
Fail-open OAuth guard in Apache Camel routes
Apache Camel camel-oauth processors meant to protect a route did not stop the exchange when authentication could not be completed. On the ordinary request path of a route configured to require OAuth, an unauthenticated remote caller reached the protected endpoint as if authentication had succeeded. No special configuration or prior access is required. Camel 4.11.0 before 4.18.5 and 4.19.0 before 4.22.1 are affected.
What to do: Upgrade to Camel 4.23.0, or 4.18.5 (4.18.x LTS) or 4.22.1 (4.22.x LTS). If you cannot upgrade yet, add an explicit authorization check after the OAuth processor and confirm the route stops on failure.
| Product | Affected | Fixed in |
|---|---|---|
| Apache Camel | 4.11.0 before 4.18.5; 4.19.0 before 4.22.1 | 4.18.5 (4.18.x LTS), 4.22.1 (4.22.x LTS), 4.23.0 |
Order-of-magnitude estimate by the model from install counts, market share and public scan data it knows; verify before quoting.
Improper Authentication vulnerability in Apache Camel OAuth component. This issue affects Apache Camel: from 4.11.0 before 4.18.5, from 4.19.0 before 4.22.1. The camel-oauth processors that guard a route did not stop the exchange when authentication could not be completed. Where a failure to establish an authenticated session should have terminated routing and returned an error to the caller, the processors fell through and returned control to the route, so the request continued to the protected endpoint as though authentication had succeeded. The effect is a fail-open authentication guard: an unauthenticated caller reached whatever the route did next. The condition is reached on the ordinary request path of a route configured to require OAuth, and needs no special configuration or prior access on the caller's part. Upgrade to Apache Camel 4.23.0, which fixes the issue. Users on the 4.18.x LTS releases stream should upgrade to 4.18.5. Users on the 4.22.x LTS releases stream should upgrade to 4.22.1. The processors now stop the exchange and set the appropriate error status whenever an authenticated session cannot be established, so a failed authentication no longer reaches the protected part of the route. For deployments that cannot upgrade immediately, place an explicit authorization check after the OAuth processor rather than relying on it to halt the exchange, and verify that the route stops on failure.
Eight critical and high issues span Camel K and Camel components, with fixes that differ by branch.
Today 840 readers · 1.1K views · 843 reads · all time 159K views