Skip to content
NewA calmer, faster ZeroHour

HTTP::Server::PSGI before 1.0056 crashes on large Content-Length

Original title: CVE-2026-115825: HTTP::Server::PSGI versions before 1.0056 for Perl allow a single request to crash the server by declaring a large Content-Length

oss-security ()
AI summary · x-ai/grok-4.7Summaries by Vani AI

One request that declares a large Content-Length can crash the PSGI server; 1.0056 is the fixed release.

Robert Rothenberg posted CVE-2026-115825 for HTTP::Server::PSGI, part of Plack. Versions before 1.0056 let a single request crash the server by declaring a large Content-Length. The note points to the Plack distribution on MetaCPAN and GitHub.

Key facts
  • The crash is triggered by one request with a large Content-Length.
  • Affected releases are HTTP::Server::PSGI before 1.0056.
  • The report was posted to oss-security on October 25.
Security assessment · AI, from the article

Impact: A single request can crash the server

ProductAffectedFixed in
Plack HTTP::Server::PSGIbefore 1.00561.0056
What to do
  1. 1.Upgrade HTTP::Server::PSGI to 1.0056 or later.
Analyze CVE-2026-115825 with Vani AIImpact, affected versions, exploitation, mitigations and detection

Vulnerabilities mentioned

All
CVEVulnerabilityCVSSEPSSSignalsPublished
CVE-2026-115825
Remote memory-exhaustion crash in HTTP::Server::PSGI before 1.0056
——

From the original article

Posted by Robert Rothenberg on Oct 25 ======================================================================== https://metacpan. org/dist/Plack https://github. com/plack/Plack...

A short excerpt; the article and its images belong to the publisher. Summary, key facts and assessment above are AI-written from the article and can be wrong.