Skip to content
NewA calmer, faster ZeroHour
VulnerabilityPoC4 · 2 reads

CVE-2025-5352

CVSS 3.1
9.6 critical
EPSS
<1%p43
Published
·
Modified
Analyze CVE-2025-5352 with Vani AIImpact, affected versions, exploitation status, mitigations and detection

Description · NVD

A critical stored Cross-Site Scripting (XSS) vulnerability exists in the Analytics component of lunary-ai/lunary versions up to 1.9.23, where the NEXT_PUBLIC_CUSTOM_SCRIPT environment variable is directly injected into the DOM using dangerouslySetInnerHTML without any sanitization or validation. This allows arbitrary JavaScript execution in all users' browsers if an attacker can control the environment variable during deployment or through server compromise. The vulnerability can lead to complete account takeover, data exfiltration, malware distribution, and persistent attacks affecting all users until the environment variable is cleaned. The issue is fixed in version 1.9.25.

Vendors
lunary
Products
lunary
Weakness
CWE-79
Vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H

In the news

1 story