Skip to content
NewA calmer, faster ZeroHour
Vulnerability3 · 1 read

CVE-2026-103552

Stack Overflow in Apache Directory LDAP API Before Bind

CVSS 3.1
7.3 high
EPSS
—
Published
·
Modified
Analyze CVE-2026-103552 with Vani AIImpact, affected versions, exploitation status, mitigations and detection

Apache Directory LDAP API versions 1.2.0 before 1.2.9 contain a stack overflow (CWE-121) in the server-side decoder. Before a client binds, it can send a deeply nested LDAP search filter that overflows the stack while the filter is decoded. CVSS 3.1 rates this 7.3 (high): the flaw is reachable over the network with low complexity, no privileges, and no user interaction, with low impact to confidentiality, integrity, and availability. Anyone running a service that uses the affected API to decode unauthenticated search filters is affected, including deployments of the library from 1.2.0 up to but not including 1.2.9. It is not listed in CISA KEV, and no public proof-of-concept is known.

What to do: Upgrade Apache Directory LDAP API to 1.2.9 or later. Until then, restrict network access to services that decode unauthenticated LDAP search filters with this library, and review logs for unusually deep or malformed filters from clients that have not bound.

ProductAffected
Apache Directory LDAP API1.2.0 before 1.2.9
Estimated exposure
No basis for an estimate.

Order-of-magnitude estimate by the model from install counts, market share and public scan data it knows; verify before quoting.

Description · NVD

Stack Overflow vulnerability in Apache Directory LDAP API. Before binding, a client can send a deeply nested search filter that overflows the stack in the server's decoder. This issue affects Apache Directory LDAP API: from 1.2.0 before 1.2.9. Users are recommended to upgrade to version 1.2.9, which fixes the issue.

Weakness
CWE-121
Vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

In the news

1 story