Critical Apache Struts Vulnerabilities Enables Remote Code Execution Attacks
Apache discloses four Struts flaws, including OGNL injection that can enable remote code execution.
Race condition in Apache Struts leaks dates across users
Apache Struts has a race condition (CWE-362) in the application-wide text provider used for localized messages. When a message formats a date or time argument, the formatter kept for that message is shared by concurrently served requests without isolation, so one user's date or time value can appear in another user's response, or rendering can fail and return a server error. Only applications whose localized messages format date or time arguments are affected; Struts 2.0.0–2.3.37, 2.5.0–2.5.33, 6.0.0–6.11.0, and 7.0.0–7.3.0 are in scope. There is no known public proof of concept, the issue is not in CISA KEV, and exploitation in the wild is not known. CVSS has not yet been scored.
What to do: Upgrade to Apache Struts 6.12.0 or 7.4.0. No fixed release is listed for the 2.0–2.3 or 2.5 lines, so those installs should move to 6.12.0 or 7.4.0. Apps that never format dates or times in localized messages are not affected; until you upgrade, watch for intermittent cross-user date/time values or message-rendering server errors under concurrent load.
| Product | Affected |
|---|---|
| Apache Struts | 2.0.0 through 2.3.37, 2.5.0 through 2.5.33, 6.0.0 through 6.11.0, and 7.0.0 through 7.3.0 |
Order-of-magnitude estimate by the model from install counts, market share and public scan data it knows; verify before quoting.
Concurrent execution using shared resource with improper synchronization ('race condition') vulnerability in Apache Struts. Where a localized message formats a date or time argument, the formatter retained for that message by the application-wide text provider is used by concurrently served requests without isolation, so a value belonging to one user can appear in another user's response, or the rendering can fail and surface as a server error. Applications whose localized messages format no date or time arguments are not affected. This issue affects Apache Struts: from 2.0.0 through 2.3.37, from 2.5.0 through 2.5.33, from 6.0.0 through 6.11.0, from 7.0.0 through 7.3.0. Users are recommended to upgrade to version 6.12.0 or 7.4.0, which fixes the issue.
Apache discloses four Struts flaws, including OGNL injection that can enable remote code execution.
Four Apache Struts flaws can enable remote code execution, denial of service, or cross-user data disclosure.
Apache Struts CVE-2026-104714 is a moderate race that can leak formatted dates across requests.
Today 656 readers · 803 views · 606 reads · all time 158K views