Skip to content
NewA calmer, faster ZeroHour
Vulnerability2 · 1 read

CVE-2026-105111

Stored XSS in Apache Commons BCEL Class2HTML

CVSS 4.0
2.3 low
EPSS
—
Published
·
Modified
Analyze CVE-2026-105111 with Vani AIImpact, affected versions, exploitation status, mitigations and detection

Apache Commons BCEL before 6.13.0 has a stored cross-site scripting flaw in its Class2HTML utility (CWE-79). Class2HTML emitters write strings taken from class files into generated HTML without escaping, so a report built from an attacker-controlled class file can contain injected script. Anyone who later views that HTML in a browser can have script run in that page context; the published CVSS 4.0 score is 2.3 (low), with no impact on the vulnerable system’s confidentiality, integrity, or availability and only limited subsequent-system impact, and the issue requires a user to view the report. Only deployments that use Class2HTML on possibly untrusted class files and then display the resulting pages are affected; ordinary BCEL bytecode processing is not described as vulnerable. No public proof of concept is known, and the CVE is not in CISA’s Known Exploited Vulnerabilities catalog.

What to do: Upgrade Apache Commons BCEL to 6.13.0. Until then, do not run Class2HTML on untrusted or attacker-supplied class files, and do not serve or open the generated HTML in a browser context that can access sensitive data.

ProductAffected
Apache Software Foundation Apache Commons BCELbefore 6.13.0
Estimated exposure
nicheNo basis for an estimate.

Order-of-magnitude estimate by the model from install counts, market share and public scan data it knows; verify before quoting.

Description · NVD

Improper neutralization of input during web page generation ('cross-site scripting') vulnerability in Apache Commons BCEL. This only happens when you're using Class2HTML to generate webpages for possibly-attacker-controlled class files, where Class2HTML emitters write attacker class-file strings into HTML unescaped (stored XSS in reports). This issue affects Apache Commons BCEL: before 6.13.0. Users are recommended to upgrade to version 6.13.0, which fixes the issue.

Weakness
CWE-79
Vector
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X

In the news

1 story