Skip to content
NewA calmer, faster ZeroHour

CVE-2026-112816

Improper certificate validation in Canonical LXD HTTPS listener

CVSS 4.0
10.0 critical
EPSS
—
Published
·
Modified
Analyze CVE-2026-112816 with Vani AIImpact, affected versions, exploitation status, mitigations and detection

Canonical LXD improperly validates certificates on its HTTPS listener. An unauthenticated remote attacker can present a crafted certificate chain and authenticate as any trusted client, gaining full access to the cluster and the virtual machines it manages. Affected releases are LXD 4.0.14, 5.0.10, 5.21.8, and 6.9 before the fixed builds.

What to do: Upgrade LXD to 4.0.15, 5.0.11, 5.21.9, or 6.10.1, matching the installed release line.

ProductAffectedFixed in
Canonical LXD4.0.14, 5.0.10, 5.21.8, 6.9 before 4.0.15, 5.0.11, 5.21.9, 6.10.14.0.15, 5.0.11, 5.21.9, 6.10.1
Estimated exposure
No basis for an estimate.

Order-of-magnitude estimate by the model from install counts, market share and public scan data it knows; verify before quoting.

Description · NVD

Improper certificate validation in the HTTPS listener in Canonical LXD 4.0.14, 5.0.10, 5.21.8, 6.9 before 4.0.15, 5.0.11, 5.21.9, 6.10.1 allows an unauthenticated attacker to authenticate as any trusted client and gain full access to the cluster and managed virtual machines via a crafted certificate chain.

Weakness
CWE-295
Vector
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X

In the news

1 story