Skip to content
NewA calmer, faster ZeroHour

CVE-2026-116593

Sensitive config leak via Kafka Connect validate API

CVSS
—
EPSS
—
Published
·
Modified
Analyze CVE-2026-116593 with Vani AIImpact, affected versions, exploitation status, mitigations and detection

Apache Kafka Connect's REST endpoint /connector-plugins/{connector-type}/config/validate resolves configuration through installed Configuration Providers, which are meant to hide sensitive values until runtime. An attacker who can reach that endpoint can force those providers to return the values in plaintext. Connect workers that have configuration providers installed and expose the validate API are affected.

What to do: Upgrade Kafka Connect to 4.2.2, 4.3.2, 4.4.0, or above.

ProductAffectedFixed in
Apache Kafka Connect—4.2.2, 4.3.2, 4.4.0 or above
Estimated exposure
No basis for an estimate.

Order-of-magnitude estimate by the model from install counts, market share and public scan data it knows; verify before quoting.

Description · NVD

Apache Kafka Connect has the /connector-plugins/{connector-type}/config/validate endpoint on its REST API to validate connector configurations. Apache Kafka Connect also support Configuration Providers which enable to hide the values of sensitive configuration and only resolve them at runtime. An attacker with access to the validate endpoint can use it to resolve and return plaintext values via any of the configuration providers installed on a Connect worker. Users are recommended to upgrade to version 4.2.2, 4.3.2, 4.4.0 or above, which fix this issue.

In the news

1 story