Skip to content
NewA calmer, faster ZeroHour

CVE-2026-12957

CVSS 4.0
8.5 high
EPSS
<1%p7
Published
·
Modified
Analyze CVE-2026-12957 with Vani AIImpact, affected versions, exploitation status, mitigations and detection

Description · NVD

Improper trust boundary enforcement in Language Servers for AWS before version 1.65.0 on all supported platforms may allow a for arbitrary code execution. If a local user opens a maliciously crafted workspace, any commands within the project configuration files may be automatically executed. This issue requires the user to trust the workspace when prompted. To remediate this issue, users should upgrade to Language Servers for AWS version 1.65.0 or higher.

Ecosystems
npm
Weakness
CWE-732
Vector
CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
GHSA
GHSA-xhcr-j4j9-3gh7 (high)

In the news

3 stories