USN-8789-1: strongSwan vulnerabilities
Ubuntu patches strongSwan vulnerabilities allowing remote crashes (CVE-2026-78123) and information disclosure (CVE-2026-78124).
Remote DoS via Expired Pointer Dereference in strongSwan PKCS#7 Parsing
strongSwan 5.0.2 through 6.0.7 contains an expired pointer dereference (a use-after-free class flaw, CWE-825) in the code that parses PKCS#7 containers in the openssl crypto plugin. An unauthenticated remote attacker can trigger it by supplying a specially crafted PKCS#7-wrapped certificate payload during an IKE/IPsec negotiation, though the CVSS attack complexity is rated high. Successful exploitation crashes the VPN daemon, denying service to tunnel users, while confidentiality and integrity are unaffected (C:N/I:N/A:H). Any strongSwan deployment built with the openssl plugin, the default in most Linux distribution packages, is affected, and Ubuntu has shipped fixes via USN-8789-1. No public proof of concept is known, the issue is not on CISA's KEV list, and there is no indication of exploitation in the wild.
What to do: Upgrade to a strongSwan release newer than 6.0.7, or apply your distribution's patched package (Ubuntu addressed this in USN-8789-1). If the openssl plugin is not required, configure or rebuild strongSwan with an alternative crypto backend (gcrypt or botan) so PKCS#7 parsing does not run through the vulnerable code path. As defense-in-depth, restrict IKE exposure (UDP 500/4500) to trusted peers and monitor the charon daemon for unexpected crashes or restarts.
| Product | Affected |
|---|---|
| strongSwan | 5.0.2 through 6.0.7 |
Order-of-magnitude estimate by the model from install counts, market share and public scan data it knows; verify before quoting.
strongSwan 5.0.2 through 6.0.7 has an Expired Pointer Dereference in PKCS#7 parsing in the openssl plugin.
Ubuntu patches strongSwan vulnerabilities allowing remote crashes (CVE-2026-78123) and information disclosure (CVE-2026-78124).
Today 1.5K readers · 3K views · 2.2K reads · all time 161K views