Skip to content
NewA calmer, faster ZeroHour

CVE-2026-78190

XSS in WebDyne for Perl before 3.022

CVSS
—
EPSS
—
Published
·
Modified
Analyze CVE-2026-78190 with Vani AIImpact, affected versions, exploitation status, mitigations and detection

WebDyne for Perl versions 2.014 before 3.022 reflect request parameters unescaped into textfield, password_field and filefield tags. Attackers craft links to inject scripts into pages. Remote unauthenticated users can trigger it. Affected are WebDyne for Perl users on vulnerable versions.

What to do: Upgrade to WebDyne for Perl 3.022. No workaround mentioned.

ProductAffectedFixed in
WebDyne for Perl2.014 before 3.0223.022
Estimated exposure
No basis for an estimate.

Order-of-magnitude estimate by the model from install counts, market share and public scan data it knows; verify before quoting.

Description · NVD

WebDyne versions from 2.014 before 3.022 for Perl reflect request parameters unescaped into form field values, allowing cross-site scripting. The textfield, password_field and filefield tags fill their value attribute from the request parameter of the same name. WEBDYNE_CGI_AUTOESCAPE, which controls escaping of these values, defaults to off. From 2.022, WebDyne::HTML::Tiny also replaced its entity_encode method with one that returns its input unchanged, so enabling WEBDYNE_CGI_AUTOESCAPE has no effect. A remote attacker can inject script into any page using these tags through a crafted link.

Weakness
CWE-79

In the news

1 story