CVE-2026-82806: Apache APISIX: cross-request permission pollution via static permission list mutation
Apache APISIX authz-keycloak can carry one request's permissions into later requests (CVE-2026-82806).
Cross-request authorization leak in Apache APISIX
Apache APISIX from 2.3.0 before 3.7.0 has an exposure-of-data-element-to-wrong-session flaw (CWE-488) when a supported authz-keycloak configuration is in use. A request's authorization scope can persist into later requests on the same route because a static permission list is mutated, so a later request may inherit an earlier request's scope. That cross-request permission pollution can expand authorization and produce inconsistent access-control decisions for subsequent callers. Only deployments on the affected versions that use this authz-keycloak setup are impacted. No public proof of concept is known and the issue is not in CISA KEV.
What to do: Upgrade Apache APISIX to 3.7.0 or later. Until then, review routes that use the authz-keycloak plugin and treat authorization decisions on those routes as potentially inconsistent across requests; after upgrading, re-check access logs for unexpected grants on shared routes.
| Product | Affected |
|---|---|
| Apache Software Foundation APISIX | from 2.3.0 before 3.7.0 |
Order-of-magnitude estimate by the model from install counts, market share and public scan data it knows; verify before quoting.
Exposure of data element to wrong session vulnerability in Apache APISIX. This issue affects Apache APISIX: from 2.3.0 before 3.7.0. Under a supported authz-keycloak configuration, a request's authorization scope could persist into later requests on the same route, leading to unintended authorization expansion and inconsistent access-control decisions. Users are recommended to upgrade to version 3.7.0 or higher, which fixes the issue.
Apache APISIX authz-keycloak can carry one request's permissions into later requests (CVE-2026-82806).
Today 840 readers · 1.1K views · 843 reads · all time 159K views