[20260912] - Core - XSS in module list
Unescaped module-list values in Joomla CMS enable XSS; fixed in versions 5.4.9 and 6.1.4.
XSS in Joomla! core module list (4.0.0–5.4.8, 6.0.0–6.1.3)
Joomla! core fails to escape user-supplied values in the module list layout, creating a cross-site scripting (CWE-79) flaw. An attacker who already has high-privilege backend access can place those values so that script runs in the browser of an administrator who views the module list (network-reachable, low complexity, passive user interaction). On the vulnerable site that can expose or alter high-value data and admin actions, with only limited availability impact and no follow-on impact scored for other systems. Sites running Joomla 4.0.0 through 5.4.8 or 6.0.0 through 6.1.3 are affected. CVSS 4.0 is 5.9 (medium) with exploit maturity unreported; it is not on the CISA KEV list and no public proof-of-concept is known.
What to do: Upgrade Joomla! core to a release outside the affected ranges (newer than 5.4.8 on the 4.x/5.x line, or newer than 6.1.3 on the 6.x line) from the official 12 September 2026 security update. Until that is applied, limit backend accounts to trusted administrators and review module records for unexpected markup in fields shown on the module list. No public exploit is known; prioritize admin-session protection because a successful attack runs in a privileged user's browser.
| Product | Affected |
|---|---|
| Joomla! Core | 4.0.0 through 5.4.8 and 6.0.0 through 6.1.3 |
Order-of-magnitude estimate by the model from install counts, market share and public scan data it knows; verify before quoting.
Joomla! Core - [20260912] - Core - XSS in module list in Joomla 4.0.0-5.4.8, 6.0.0-6.1.3 - The module list layout did not properly escape user supplied values, leading to an XSS vector.
Unescaped module-list values in Joomla CMS enable XSS; fixed in versions 5.4.9 and 6.1.4.
Today 2.1K readers · 11K views · 8.7K reads · all time 157K views