CVE-2026-92414: Apache Jackrabbit: Pre-auth hijack of cached sessions via derivable WebDAV lock tokens
CVE-2026-92414 lets unauthenticated attackers hijack cached Apache Jackrabbit WebDAV sessions and is rated CVSS 9.3.
Session fixation in Apache Jackrabbit WebDAV
Apache Jackrabbit’s WebDAV server has a session fixation and session-reuse flaw (CWE-384). If a request’s Lock-Token, TransactionId, SubscriptionId, or If-header value matches a cached token, the server attaches that cached authenticated session without checking credentials. A remote unauthenticated attacker can then act as the user who owns the cached session, with high impact to confidentiality and integrity of repository content and no direct availability impact (CVSS 4.0 9.3); related reporting describes the lock tokens as derivable. Affected releases are 2.20.0–2.20.17, 2.22.0–2.22.4, and 2.23.0–2.23.5, fixed in 2.20.18, 2.22.5, and 2.23.6. It is not in CISA KEV and no public proof-of-concept is known.
What to do: Upgrade Apache Jackrabbit to 2.23.6, 2.22.5, or 2.20.18 on the matching release line. Until that is done, do not expose the WebDAV endpoint to untrusted networks, and after patching invalidate existing locks and authenticated sessions so previously cached sessions cannot be reused. Review WebDAV access logs for requests that supply Lock-Token, TransactionId, SubscriptionId, or If headers without a matching authentication.
| Product | Affected |
|---|---|
| Apache Software Foundation Apache Jackrabbit | 2.20.0 through 2.20.17, 2.22.0 through 2.22.4, and 2.23.0 through 2.23.5 |
Order-of-magnitude estimate by the model from install counts, market share and public scan data it knows; verify before quoting.
: Session Fixation / Session Reuse across Users vulnerability in Apache Jackrabbit. Jackrabbit WebDAV server attaches a cached authenticated session on any Lock-Token/TransactionId/SubscriptionId/If-header field token match with no credential check. This issue affects Apache Jackrabbit: from 2.23.0 through 2.23.5, from 2.22.0 through 2.22.4, from 2.20.0 through 2.20.17. Users are recommended to upgrade to versions 2.23.6, 2.22.5, or 2.20.18 which fix the issue.
CVE-2026-92414 lets unauthenticated attackers hijack cached Apache Jackrabbit WebDAV sessions and is rated CVSS 9.3.
Today 656 readers · 803 views · 606 reads · all time 158K views