Skip to content
NewA calmer, faster ZeroHour
Vulnerability7 · 5 reads

CVE-2026-94276

Improper Authentication in Apache APISIX OpenID-Connect

CVSS 4.0
5.1 medium
EPSS
—
Published
·
Modified
Analyze CVE-2026-94276 with Vani AIImpact, affected versions, exploitation status, mitigations and detection

Apache APISIX 3.12.0 through 3.18.0 has an improper authentication flaw (CWE-287) in the openid-connect plugin when it performs remote token introspection against an authorization server that serves multiple issuers. A token that introspects as active for one issuer can be accepted on a route restricted to a different issuer, so the intended issuer check is not enforced. An attacker who already holds a valid token for one issuer on that shared authorization server may reach routes meant for another issuer; CVSS 4.0 rates this 5.1 (medium), with high subsequent confidentiality and low subsequent integrity impact and no direct impact on the gateway itself. Only deployments using that plugin configuration are affected. No public proof-of-concept is known, and the issue is not in CISA KEV.

What to do: Upgrade Apache APISIX to 3.19.0 or later. Until then, review routes that use the openid-connect plugin with remote introspection against an authorization server that serves more than one issuer, and do not rely on per-route issuer restrictions for access control in that setup.

ProductAffected
Apache APISIX3.12.0 through 3.18.0
Estimated exposure
No basis for an estimate.

Order-of-magnitude estimate by the model from install counts, market share and public scan data it knows; verify before quoting.

Description · NVD

Improper Authentication vulnerability in Apache APISIX. On a route using openid-connect plugin with remote introspection against an authorization server that serves multiple issuers, a token that introspects as active for one issuer may get accepted on a route restricted to another. This issue affects Apache APISIX: from 3.12.0 through 3.18.0. Users are recommended to upgrade to version 3.19.0, which fixes the issue.

Weakness
CWE-287
Vector
CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:N/VI:N/VA:N/SC:H/SI:L/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X

In the news

1 story