Skip to content
NewA calmer, faster ZeroHour
Exploit / PoChighExploited in the wild

BTCPay Server hot wallet thefts target outdated instances

Original title: BTCPay Server warns of hot wallet thefts targeting outdated instances

BleepingComputerby Bill Toulas ()2 min read1
Part of a story covered by 2 sourcesBTCPay Server Warns of Hot Wallet Drains on Outdated VersionsMerged summary & timeline
AI summary · x-ai/grok-4.7Summaries by Vani AI

Attackers drain hot wallets on instances running version 2.4.1 or earlier; update to 2.4.7 urged.

BTCPay Server identified an attack vector allowing administrator login on versions older than 2.4.2, leading to hot wallet drains. The maintainer urges updating to 2.4.7. No attacks reported on the latest 2.4.7 release.

Key facts
  • Attack targets versions 2.4.1 and earlier
  • Update to 2.4.7 recommended
  • Investigation ongoing
  • Previously warned about flaw in 2.4.2
  • No credible reports for latest version
Security assessment · AI, from the articleExploited in the wild

Impact: unauthorized access to and theft from hot wallets

What to do
  1. 1.Update BTCPay Server to version 2.4.7
  2. 2.Shut down outdated instances immediately
Analyze this story with Vani AIImpact, who is affected and what defenders should do, in a new chat

From the original article

2 min read at bleepingcomputer.com

The maintainer of BTCPay Server, an open-source cryptocurrency payment processor, has urged users to install the latest version as hackers have been draining "hot wallets" on instances running older versions. [...]

BleepingComputer

By Bill Toulas · bleepingcomputer.com

Read the full article at BleepingComputer

A short excerpt; the article and its images belong to the publisher. Summary, key facts and assessment above are AI-written from the article and can be wrong.