Skip to content
NewA calmer, faster ZeroHour
StoryExploit / PoChighExploited in the wild

BTCPay Server Warns of Hot Wallet Drains on Outdated Versions

2 sources · 2 articlesFirst reported Updated ()1
What's new

First merged summary.

Merged summary · x-ai/grok-4.7 · rewritten as coverage arrivesSummaries by Vani AI

BTCPay Server urges operators of versions older than 2.4.2 to shut down immediately after hot wallet drains reported.

BTCPay Server issued an urgent warning after reports of attackers draining hot wallets on its servers. The open-source payment processor instructed operators to run ./btcpay-down.sh and keep installations offline while it investigates. Early findings point to an attack vector allowing administrator login on versions older than 2.4.2, though the initial access method remains unconfirmed. Update to 2.4.7 is recommended; no attacks reported on the latest release. Investigation ongoing with no confirmed losses.

Key facts
  • Affected versions older than 2.4.2
  • Update to 2.4.7 recommended
  • Run ./btcpay-down.sh until investigation complete
  • No confirmed losses or affected instances
  • Public servers on 2.4.7 not attacked
  • Previously warned about flaw in 2.4.2
Analyze this story with Vani AIImpact, who is affected and what defenders should do, in a new chat

What each outlet adds

beyond the shared facts
  • Cyber Security NewsOperators urged to run down.sh script and keep offline, no attacks on 2.4.7
  • BleepingComputerTargets versions 2.4.1 and earlier, previously warned about 2.4.2 flaw

Coverage

oldest first · one row per article · UTC
  1. · 19h ago Cyber Security NewsFirst report

    BTCPay Server warns of hot wallet drains

    Operators urged to shut down BTCPay Servers immediately after reports of Bitcoin hot wallet drains.

  2. · 9h ago BleepingComputer

    BTCPay Server hot wallet thefts target outdated instances

    Attackers drain hot wallets on instances running version 2.4.1 or earlier; update to 2.4.7 urged.