Skip to content
NewA calmer, faster ZeroHour
VulnerabilityPoC ×42 · 1 read

CVE-2025-29927

Middleware Authorization Bypass in Vercel Next.js (CVE-2025-29927)

CVSS 3.1
9.1 critical
EPSS
99%p100
Published
·
Modified
Analyze CVE-2025-29927 with Vani AIImpact, affected versions, exploitation status, mitigations and detection

CVE-2025-29927 is a critical (CVSS 9.1) authorization bypass in Vercel's Next.js, a widely used React framework for full-stack web applications: when an application performs its authorization checks in middleware, a remote unauthenticated attacker can bypass those checks by sending a request containing the x-middleware-subrequest header, which causes the middleware to be skipped. Successful exploitation grants access to otherwise protected routes and resources without valid credentials, with high impact on confidentiality and integrity and no availability impact (CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N). All Next.js releases starting in version 1.11.4 and prior to the branch-specific fixed versions 12.3.5, 13.5.9, 14.2.25, and 15.2.3 are affected, so any Next.js application that relies on middleware for authorization is exposed. Exploitation is not yet confirmed in the provided data: the flaw is not in CISA KEV and no public proof-of-concept is catalogued, but EPSS assigns a 99.2% (100th percentile) probability of exploitation within 30 days, and national authorities such as the UK NCSC are urging immediate patching.

What to do: Upgrade Next.js to 12.3.5, 13.5.9, 14.2.25, or 15.2.3, matching your application's release branch. If patching is infeasible, block or strip the x-middleware-subrequest header from external requests at the reverse proxy, CDN, or WAF before they reach the Next.js application. Audit whether your applications perform authorization checks in middleware, and verify that protected routes cannot be reached without authentication after remediation.

ProductAffected
Vercel Next.js>= 1.11.4 and prior to 12.3.5 (fixed in 12.3.5)
Vercel Next.js13.x line prior to 13.5.9 (fixed in 13.5.9)
Vercel Next.js14.x line prior to 14.2.25 (fixed in 14.2.25)
Vercel Next.js15.x line prior to 15.2.3 (fixed in 15.2.3)
Estimated exposure
masspotentially millions of Next.js deployments worldwide, with plausibly hundreds of thousands of sites/apps actually exposed (only those using middleware for… — Next.js is one of the most widely deployed web/React frameworks, with public technology surveys and Vercel platform adoption putting active deployments in the millions, but only applications that perform authorization inside middleware are…

Order-of-magnitude estimate by the model from install counts, market share and public scan data it knows; verify before quoting.

Description · NVD

Next.js is a React framework for building full-stack web applications. Starting in version 1.11.4 and prior to versions 12.3.5, 13.5.9, 14.2.25, and 15.2.3, it is possible to bypass authorization checks within a Next.js application, if the authorization check occurs in middleware. If patching to a safe version is infeasible, it is recommend that you prevent external user requests which contain the x-middleware-subrequest header from reaching your Next.js application. This vulnerability is fixed in 12.3.5, 13.5.9, 14.2.25, and 15.2.3.

Vendors
vercel
Products
next.js
Weakness
CWE-285, CWE-863
Vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N

In the news

12 stories