libvips vulnerabilities in Ubuntu
libvips PDF handling and integer overflow issues in Ubuntu 16.04 to 24.04 LTS could cause crashes or arbitrary code execution.
libvips is a demand-driven, horizontally threaded image processing library. For versions 8.17.1 and below, when libvips is compiled with support for PDF input via poppler, the pdfload operation is affected by a buffer read overflow when parsing the header of a crafted PDF with a page that defines a width but not a height. Those using libvips compiled without support for PDF input are unaffected as well as thosewith support for PDF input via PDFium. This issue is fixed in version 8.17.2. A workaround for those affected is to block the VipsForeignLoadPdf operation via vips_operation_block_set, which is available in most language bindings, or to set VIPS_BLOCK_UNTRUSTED environment variable at runtime, which will block all untrusted loaders including PDF input via poppler.
libvips PDF handling and integer overflow issues in Ubuntu 16.04 to 24.04 LTS could cause crashes or arbitrary code execution.
Today 670 readers · 791 views · 175 reads · all time 173K views