libvips vulnerabilities in Ubuntu
libvips PDF handling and integer overflow issues in Ubuntu 16.04 to 24.04 LTS could cause crashes or arbitrary code execution.
40
libvips is a fast image processing library with low memory needs. The `vipsload` operation in versions before and including 8.18.0 could incorrectly determine image dimensions leading to an integer overflow and a subsequent heap-based buffer overflow. This has been patched in version 8.18.1.
libvips PDF handling and integer overflow issues in Ubuntu 16.04 to 24.04 LTS could cause crashes or arbitrary code execution.
Today 670 readers · 793 views · 177 reads · all time 173K views