Skip to content
NewA calmer, faster ZeroHour
Exploit / PoCcriticalExploited in the wild

CISA lists critical Google Brotli flaw CVE-2026-111497 as exploited

Original title: AL26-027 - Critical vulnerability impacting Google Brotli – CVE-2026-111497

Canadian Centre for Cyber Security ()2 min read1
Part of a story covered by 9 sourcesCISA lists exploited Brotli decoder flaw CVE-2026-111497Merged summary & timeline
AI summary · x-ai/grok-4.7Summaries by Vani AI

Out-of-bounds writes in the decoder can yield code execution; fixed builds are 1.0.10, 1.1.1, and 1.2.1.

Canada’s Cyber Centre warned on October 28, 2026 about CVE-2026-111497, an unauthenticated out-of-bounds write in the Google Brotli decoder known as Broccoli2Shell. Specially crafted compressed data can corrupt memory, disclose information, crash a process, or execute arbitrary code. Software that may bundle vulnerable Brotli includes Node.js, Microsoft .NET, PowerShell, Bun, Envoy Proxy, Istio, and the Python Brotli and brotlicffi packages. CISA added the CVE to its Known Exploited Vulnerabilities catalog on October 27, 2026.

Unconfirmed: One sentence tells BeyondTrust Remote Support users to upgrade, but the version table covers only Brotli.

Key facts
  • Fixed Brotli releases named in the alert are 1.0.10, 1.1.1, and 1.2.1.
  • Listed affected ranges are 1.0.3 before 1.0.10, 1.1.0 before 1.1.1, and 1.2.0 before 1.2.1.
  • Until patched, the alert says to stop processing untrusted Brotli content.
Security assessment · AI, from the articleExploited in the wild

Impact: Unauthenticated memory corruption or arbitrary code execution

ProductAffectedFixed in
Google Brotli1.0.3 prior to 1.0.10; 1.1.0 prior to 1.1.1; 1.2.0 prior to 1.2.11.0.10, 1.1.1, 1.2.1
What to do
  1. 1.Upgrade Brotli to 1.0.10, 1.1.1, or 1.2.1 on the affected release line.
  2. 2.Prioritize internet-facing apps and dependencies that bundle vulnerable Brotli.
  3. 3.Until updated, block untrusted Brotli-compressed input to affected applications.
Analyze CVE-2026-111497 with Vani AIImpact, affected versions, exploitation, mitigations and detection

Vulnerabilities mentioned

All
CVEVulnerabilityCVSSEPSSSignalsPublished
CVE-2026-111497
Buffer overflow in Google Brotli decoder 1.0.3–1.2.0
9.283%KEVPoC ×25
KEV

From the original article

2 min read at cyber.gc.ca

Number: AL26-027 Date: October 28, 2026 Audience This Alert is intended for IT professionals and managers. Purpose An Alert is used to raise awareness of a recently identified cyber threat that may impact cyber information assets, and to provide additional detection and mitigation advice to recipients.

Canadian Centre for Cyber Security

cyber.gc.ca

Read the full article at Canadian Centre for Cyber Security

A short excerpt; the article and its images belong to the publisher. Summary, key facts and assessment above are AI-written from the article and can be wrong.