Skip to content
NewA calmer, faster ZeroHour
Exploit / PoCcriticalExploited in the wild

CISA lists exploited Node2Shell flaw CVE-2026-111497

Original title: Node2Shell Vulnerability Actively Exploited in the Wild, CISA Warns

Cyber Security Newsby Guru Baran ()6 min read6
Part of a story covered by 9 sourcesCISA lists exploited Brotli decoder flaw CVE-2026-111497Merged summary & timeline
AI summary · x-ai/grok-4.7Summaries by Vani AI

Federal agencies must fix it by November 10; patched Node.js releases are 22.23.4, 24.22.1 and 26.12.1.

CISA added CVE-2026-111497, called Node2Shell, to the Known Exploited Vulnerabilities catalog on October 27, 2026, after live exploit traffic hit Node.js servers. The flaw is an out-of-bounds write in the Google Brotli decoder, scored 9.2, that a remote attacker can use to corrupt memory, leak data, crash an app, or possibly run code. Fixed Brotli releases are 1.0.10, 1.1.1 and 1.2.1. End-of-life Node.js 20.x, 23.x and 25.x will not be fixed. Ransomware use is listed as unknown.

Unconfirmed: CISA marks ransomware use as unknown and does not require forensic triage under BOD 26-04.

Key facts
  • CISA says federal agencies must remediate by November 10, 2026.
  • Affected Node.js lines include 22.x, 24.x and 26.x plus EOL branches.
  • Google Brotli 1.0.3 through 1.2.0 is affected on all platforms.
  • Bun before 1.4.4 and Python Brotli and brotlicffi also need updates.
  • process.versions.brotli can still show 1.2.0 on patched Node.js builds.
Security assessment · AI, from the articleExploited in the wild

Impact: Unauthenticated memory corruption, data leak, crash, or code execution

ProductAffectedFixed in
Google Brotli1.0.3 through 1.2.01.0.10, 1.1.1, and 1.2.1
Node.js22.x, 24.x, 26.x, and EOL 20.x, 23.x, 25.x22.23.4, 24.22.1, and 26.12.1
Oven Bunbefore 1.4.41.4.4
Google Python Brotli—1.2.1
brotlicffi—1.2.1.0
What to do
  1. 1.Install Node.js 22.23.4, 24.22.1, or 26.12.1, or Brotli 1.0.10, 1.1.1, or 1.2.1.
  2. 2.Federal civilian agencies must remediate by November 10, 2026.
  3. 3.Check the Node.js release, not process.versions.brotli, which can still read 1.2.0.
Analyze CVE-2026-111497 with Vani AIImpact, affected versions, exploitation, mitigations and detection

Vulnerabilities mentioned

All
CVEVulnerabilityCVSSEPSSSignalsPublished
CVE-2026-111497
Buffer overflow in Google Brotli decoder 1.0.3–1.2.0
9.283%KEVPoC ×25
KEV

Indicators of compromise

auto-extracted · verify before use · export allAll
TypeIndicatorContext
ipv494.154.43.7927844f3b772668204737a4e7602a2290c991c93c5c4b. It came from 94.154.43.7, an address ELLIO rates as malicious with high confidence.
sha2567fcbdaaecd4419e2930927844f3b772668204737a4e7602a2290c991c93c5c4bTC. ELLIO saw a single 23,069,983-byte request with SHA-256 7fcbdaaecd4419e2930927844f3b772668204737a4e7602a2290c991c93c5c4b. It came from 94.154.43.7, an address ELLIO rates as malici

From the original article

6 min read at cybersecuritynews.com

CISA has added the Node2Shell flaw, tracked as CVE-2026-111497, to its Known Exploited Vulnerabilities catalog. Attackers are already sending live exploit traffic at Node. js servers, so teams should patch right away.

Cyber Security News

By Guru Baran · cybersecuritynews.com

Read the full article at Cyber Security News

A short excerpt; the article and its images belong to the publisher. Summary, key facts and assessment above are AI-written from the article and can be wrong.