Skip to content
NewA calmer, faster ZeroHour

Apache OpenOffice vulnerable to heap-based buffer overflow in PDF parsing (CVE-2026-90624)

Original title: CVE-2026-90624: Apache OpenOffice: PDF File Parsing Heap based Buffer-Overflow-Remote Code Execution Vulnerability

oss-security ()
Part of a story covered by 7 sourcesMultiple Vulnerabilities in Apache OpenOffice 4.1.16 Fixed in 4.1.17Merged summary & timeline
AI summary · x-ai/grok-4.7Summaries by Vani AI

Heap-based buffer overflow in PDF import code of Apache OpenOffice through 4.1.16 can lead to remote code execution.

An unchecked memory access in the PDF import code of Apache OpenOffice versions through 4.1.16 allows a crafted PDF to cause an out-of-bounds memory write. This could crash the program or cause memory corruption and potentially lead to remote code execution. The vulnerability was reported on oss-security. Users are recommended to upgrade to version 4.1.17.

Key facts
  • Heap-based buffer overflow in PDF parsing
  • Affects Apache OpenOffice through 4.1.16
  • Fixed in version 4.1.17
  • Credit: Anonymous working with TrendAI Zero Day Initiative
Security assessment · AI, from the article

Impact: remote code execution via out-of-bounds write

What to do
  1. 1.Upgrade to Apache OpenOffice 4.1.17
Analyze CVE-2026-90624 with Vani AIImpact, affected versions, exploitation, mitigations and detection

Vulnerabilities mentioned

All
CVEVulnerabilityCVSSEPSSSignalsPublished
CVE-2026-90624
———

From the original article

Posted by Arrigo Marchiori on Nov 03 Severity: important Affected versions: - Apache OpenOffice through 4. 1. 16 Description: An unchecked memory access in the PDF import code of Apache OpenOffice versions through 4.

A short excerpt; the article and its images belong to the publisher. Summary, key facts and assessment above are AI-written from the article and can be wrong.