Skip to content
NewA calmer, faster ZeroHour

Apache OpenOffice vulnerable to out-of-bounds write in PDF import (CVE-2026-90626)

Original title: CVE-2026-90626: Apache OpenOffice: Out-of-bounds write when importing encrypted PDF files

oss-security ()
Part of a story covered by 7 sourcesMultiple Vulnerabilities in Apache OpenOffice 4.1.16 Fixed in 4.1.17Merged summary & timeline
AI summary · x-ai/grok-4.7Summaries by Vani AI

Out-of-bounds write when importing encrypted PDF files in Apache OpenOffice through 4.1.16 allows program crash or memory corruption.

Apache OpenOffice versions through 4.1.16 allow a crafted PDF to cause an out-of-bounds memory write during encrypted PDF import. This can lead to program crash or memory corruption. The vulnerability was reported on oss-security. Users are recommended to upgrade to version 4.1.17.

Key facts
  • Out-of-bounds write in PDF import code
  • Affects Apache OpenOffice through 4.1.16
  • Fixed in version 4.1.17
Security assessment · AI, from the article

Impact: out-of-bounds memory write causing crash or corruption

What to do
  1. 1.Upgrade to Apache OpenOffice 4.1.17
Analyze CVE-2026-90626 with Vani AIImpact, affected versions, exploitation, mitigations and detection

Vulnerabilities mentioned

All
CVEVulnerabilityCVSSEPSSSignalsPublished
CVE-2026-90626
———

From the original article

Posted by Arrigo Marchiori on Nov 03 Severity: important Affected versions: - Apache OpenOffice through 4. 1. 16 Description: An uncontrolled memory access in the PDF import code of Apache OpenOffice versions through 4.

A short excerpt; the article and its images belong to the publisher. Summary, key facts and assessment above are AI-written from the article and can be wrong.